attachments-2020-05-eMzE36PU5ecf670b69e05.jpg

1、下载源码文件

<br>sudo git clone https://gitee.com/swoole/swoole.git

 

2.由于下载的只是源码没有configure文件,所以我们需要用phpize生成。由于本地库缺少autoconf所以需要安装apt-get install autoconf 。

www:/data/swoole$ sudo /usr/local/php/bin/phpize
Configuring for:
PHP Api Version:         20170718
Zend Module Api No:      20170718
Zend Extension Api No:   320170718

执行成功。

下面可以进行配置安装了:

3.配置安装 。

sudo ./configure --prefix=/usr/local/swoole --with-php-config=/usr/local/php/bin/php-config ##指定php-config给swoole

有错报什么错,就解决什么,我这里没有报错。

4.make && make install #编译成功

Installing shared extensions:     /usr/local/php/lib/php/extensions/no-debug-non-zts-20170718/
Installing header files:          /usr/local/php/include/php

5.安装完成,配置php.ini,由于没有找到php.ini文件,所以需要从源码cp一个。

6.安装的时候如果没有指定config那么要查看php配置php.INi的路径是哪里,然后cp php.ini 到指定的目录配置swoole

 php -i | grep php.ini
  Configuration File (php.ini) Path => /usr/local/php/lib
  Loaded Configuration File => /usr/local/php/lib/php.ini